Recent Entries Friends Archive Profile Tags
 
 
 
 
 
 
We came home to no internet service tonight, but the failure mode is odd. We do have connectivity, but no DNS -- so that would be a well-understood problem, except that I can use ssh to get to my shell provide -- by name. I can also ping that host by name -- but I can't ping anything else by name. Does MacOS maintain some sort of cached state for ssh?

And when did browsers start rewriting IP addresses to domain names? I could visit my favorite web sites by IP address in principle, but when I type in an IP address the browser turns it into a domain name, tries to load that...and fails, because there's no DNS. WTF?

Verizon has been underwhelming so far, and I even mean compared to other Verizon experiences. At one point they said the line must be bad and they'd send a technician in a couple of days, then put us on hold for 10+ minutes. But how could it be a bad line if we have any connectivity at all? When the guy came back he said that there's an outage (previously he had said there wasn't), so with luck it'll come back on its own.

But if anybody reading this could tell me where to find some DNS servers that I'd be allowed to hit, I'd be grateful. I'm trying to find that on my own, but using the phone is slow going.

 
 
 
 
 
 
Google public DNS: 8.8.8.8 and 8.8.4.4
Yay! Post by email worked. :-)

Thanks for the info! Should I have to reboot the machine for new settings to take effect? I wouldn't think so, but my desktop machine isn't reacting to either new DNS settings or my phone's hotspot (hey, my phone has a hotspot, cool). I'm typing this from a laptop via the phone hotspot (I booted the laptop after setting up the phone). On the one hand I could reboot the Mini and find out, but what if it costs me ssh?
I don't believe you should have to reboot. There are configuration instructions and some diagnostic help here: http://code.google.com/speed/public-dns/docs/using.html

There's also a phone number for help on that page, but I have no idea how helpful it actually is.

If DNS lookups are still not working for you, it may be something weird with your TCP stack, or maybe caching issues? Good luck!
Thanks! Fortunately I didn't need the instructions to reconfigure first the router and then one individual machine when that failed. Unfortunately last night that didn't work -- weird. Fortunately this morning, after another router restart, things were back to working with the original settings. Now that it's working I haven't yet tried adding the Google servers back into the mix.

So hmm, maybe weird caching? That it took hours, rather than either minutes or days, to right itself puzzles me.
Actually, I misspoke: this morning when things worked I did have the Google servers in the list, but the router doesn't report using them. Doesn't matter; I'm keeping them. Thanks again for the tip!